Tailight issues..

Discussion in 'Engine Performance + Maintenance' started by SpencerW, May 30, 2020.

Car Parts
  1. SpencerW

    SpencerW Newbie

    Messages:
    10
    Likes Received:
    5
    Joined:
    Mar 19, 2020
    Location:
    Missouri
    Just finished my truck today. All tailights, brake lights, blinkers, were wroking.
    I got pulled over tonight for no rear lights.... Heres the verdict..
    Key off, manually on, i have a rear tail light with buzzer going. I hit the brake, i lose tailight and buzzer goes off..
    Turn the key on I have no rear lights.
    I have headlights etc.
    I have a coffee and cars tomorrow morning and need to get this fixed..
    Fuses appeared good..

    0529201054a_HDR.jpg
     
    HotWheelsBurban likes this.
  2. SAATR

    SAATR /\___/\___/\___/\___/\

    Messages:
    2,375
    Likes Received:
    341
    Joined:
    Dec 16, 2010
    Location:
    Loo E Z an uh
    Get the meter out and start checking power and ground. I would check the ground on the taillights first. I think the running lights and the brake lights share a ground, but the higher current of the brake lights may be causing it to lose connection when applying the brakes. Fresh build and first drive equal recheck connections.
     
    HotWheelsBurban likes this.
  3. Erik the Awful

    Erik the Awful I'm Awesome

    Messages:
    594
    Likes Received:
    496
    Joined:
    Aug 9, 2019
    Location:
    Choctaw, OK
    One rear tail light and not the other means it's in the bed wiring harness. I'm assuming you've had the bed off at some point. I'd start with a visual examination of the bed wiring harness. Make sure it's not pinched or rubbing, and that the grounds are properly connected.
     
    sewlow and HotWheelsBurban like this.
  4. Schurkey

    Schurkey I'm Awesome

    Messages:
    1,806
    Likes Received:
    975
    Joined:
    Jan 14, 2018
    Location:
    The Seasonally Frozen Wastelands
    WHAT VEHICLE??? WHAT MODEL YEAR???

    Perhaps a moderator can move this out of "Engine Performance and maintenance".

    1. How old are the rear circuit boards? Epidemic problem.

    2. Do you have the CORRECT bulbs in the sockets? No one-filament bulbs where there should be two-filament bulbs, or the other way around? You haven't screwed-up the lights by adding LEDs or some other mods...right?

    3. Detail what works and what doesn't:
    Brake lights? BOTH SIDES?
    Tail lights? BOTH SIDES?
    Left turn signal?
    Right turn signal?
    Reverse lights? BOTH SIDES?
    Four-way flashers? ALL THE WAY AROUND?

    Does any of the above change with the headlights ON vs. just the running lights?

    4. Do you have a trailer hitch wiring connector? What happens if you disconnect it and just plug the truck harness together?

    Do you have ANY lights that don't work properly up front?
     
    HotWheelsBurban likes this.
  5. sewlow

    sewlow Bitchin' Stitchin'

    Messages:
    11,229
    Likes Received:
    1,943
    Joined:
    Jun 22, 2011
    Location:
    Abbotsford B.C., Canada.
    Those look like aftermarket LED tail lights. No boards.
     
    HotWheelsBurban likes this.

Share This Page