WinALDL or Tunerpro help

Discussion in 'Engine Performance + Maintenance' started by OleGreen93, Aug 22, 2019.

Car Parts
  1. OleGreen93

    OleGreen93 Newbie

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 22, 2019
    Location:
    Shreveport, LA
    Hey everyone, new member here. Just want to say this forum has been very helpful in my efforts to get my truck running better.

    I'm currently trying to diagnose an issue with my 1993 Sierra SLE K1500 5.7 automatic where it idles very low in gear (~200 rpm according to tachometer) and seems to have a misfire at idle with a strong fuel smell going with it. The idle in gear will dip to almost stalling and then surge back up a bit when I'm at stoplights waiting with foot on the brake. The truck has a noticeable shake when it does this. It will do this dip/surging repeatedly until I start driving again.

    I bought an ALDL to USB cable and am trying to connect to the truck's computer with my Windows 10 laptop to view live data while it acts up. I have tried both WinALDL and Tunerpro software and can't get either one to talk to the truck's computer. I have my COM port for the cable set to the same as either software but not sure if there are any other things that need to be set for this to work. My ECU for the truck is Service Number: 16168625. Does the jumper in the cable need to be removed for it to communicate? I removed it and tested but no change.

    I'd really appreciate any tips you guys have with WinALDL or Tunerpro.
     
  2. RawbDidIt

    RawbDidIt I'm Awesome

    Messages:
    353
    Likes Received:
    87
    Joined:
    Mar 29, 2017
    Location:
    Dallas, TX
    Sounds like an ignition issue, could be rotor, cap, wires or spark plugs. If it's been doing this for a while your rotor and cap might be bad, but it may have fouled your plugs in a cylinder or two. I'd replace the cap and rotor and pull the plugs to see how bad they are. May be able to just clean them with some seafoam and a wire brush, or may need to replace them too.

    Sent from my SM-G965U using Tapatalk
     
  3. OleGreen93

    OleGreen93 Newbie

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 22, 2019
    Location:
    Shreveport, LA
    You may be on to something with it being ignition related. I replaced the spark plugs, wires, and distributor a few weeks ago but just a couple nights ago found one of the spark plugs arcing against the cylinder head. Pulled the plug and it was cracked at the insulation. Replaced that plug with a spare and that cleared up the arcing but still idled low in drive with misfire. These are all acdelco plugs. I will pull them all out this afternoon and replace with NGK copper plugs and verify that my wire connections are good.
     
  4. PlayingWithTBI

    PlayingWithTBI Desert Old Guy

    Messages:
    1,082
    Likes Received:
    444
    Joined:
    Jan 3, 2019
    Location:
    Tonopah, AZ
    In TunerPro RT v5 you need to download the corresponding definition files for your 8625 PCM to connect with it. The ADX file is for connecting and monitoring/data logging. The XDF file is the mask for editing your .bin file.

    http://www.tunerpro.net/downloadBinDefs.htm#GM

    http://www.gearhead-efi.com/gearhead-efi/def/

    You should not need the jumper on your cable, the 10k Ohm is for older ECMs and, of course the direct jumper is for the old paperclip trick. Do you have your BCC Bin file? It should be on your EPROM.
    upload_2019-8-22_8-46-6.png
     
    bigfutz likes this.
  5. PlayingWithTBI

    PlayingWithTBI Desert Old Guy

    Messages:
    1,082
    Likes Received:
    444
    Joined:
    Jan 3, 2019
    Location:
    Tonopah, AZ
    Make sure in "Tools/Preferences/Data Acq./Emulation tab/Configure Plug-in component button" you select Standard Serial

    upload_2019-8-22_9-3-0.png

    Then on the other side check these boxes
    upload_2019-8-22_9-7-37.png
     
    bigfutz likes this.
  6. RawbDidIt

    RawbDidIt I'm Awesome

    Messages:
    353
    Likes Received:
    87
    Joined:
    Mar 29, 2017
    Location:
    Dallas, TX
    Possible the whole box got dropped during shipping and another one is damaged as well. You never know. If it's missing and smells like gas, you're missing spark somewhere.

    Sent from my SM-G965U using Tapatalk
     
  7. OleGreen93

    OleGreen93 Newbie

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 22, 2019
    Location:
    Shreveport, LA
    Thank you very much for these links. I think this will get me up and running. I don't have the BCC bin file from my EPROM but can pull the ECM out and get that info off the EPROM if needed. Those links and screenshots you provided will be very helpful when I have a chance this afternoon to hopefully get connected to the truck.
     
  8. OleGreen93

    OleGreen93 Newbie

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 22, 2019
    Location:
    Shreveport, LA
    Following playingwithtbi's advice, I was able to get my computer connected to the truck to view live data. These screenshots were taken with the truck idling in park at full operating temp. Anyone able to see what might be the issue? I also took a recording while idling in park, idling in drive and giving it some throttle in park. Currently static ignition timing is set to 6 degrees advanced. Any help is greatly appreciated!


    1993_5.7.PNG

    1993_5.7_2.PNG
     
  9. OleGreen93

    OleGreen93 Newbie

    Messages:
    15
    Likes Received:
    0
    Joined:
    Aug 22, 2019
    Location:
    Shreveport, LA
    1993_5.7_TBI.PNG
     
  10. PlayingWithTBI

    PlayingWithTBI Desert Old Guy

    Messages:
    1,082
    Likes Received:
    444
    Joined:
    Jan 3, 2019
    Location:
    Tonopah, AZ
    1st thing I see is your idle is closer to 750 than 200, maybe your dash gauge is off? You also have some KCs (knock counts), did you start your log before starting the engine? That can account for the KCs.

    On the upper left corner of your dashboard click on that button and see if you have the option of "digital". It's easier to see what's going on. Then you can click on each cell and select/modify what you want to see or watch. Here's a screenshot of one of my data logs with a 7747 ECM. Yours may look different.

    upload_2019-8-22_17-52-0.png

    Enjoy playing with it, take it out for a drive and data log, FUN STUFF!!!
     

Share This Page