Blend door issue maybe?

Discussion in 'Feedback, Help and Suggestions' started by GeorgiaMudCow, Jun 12, 2018.

  1. GeorgiaMudCow

    GeorgiaMudCow Newbie

    Messages:
    4
    Likes Received:
    3
    Joined:
    Feb 16, 2018
    Location:
    North Florida
    Recently it got up into the 90s here in Florida. And ac is a necessity. I've noticed that, although the air coming out is cold, it seems that it's not transferring to the vents as it should. I relate it to a stock late 70s 454. Lots of noise but isn't really going anywhere. The air comes out of all the vents no matter which setting its on. But.... with each setting change, I can hear the doors moving. When switching to defrost, 90% air flow is directed to the windshield. On face/ feet setting, only 30% or so comes out and still blows 20% to defrost. I can hear the other 50% getting lost somewhere under the dash but can't locate it.

    Any ideas?
     
  2. east302

    east302 I'm Awesome

    Messages:
    1,392
    Likes Received:
    404
    Joined:
    Oct 4, 2013
    Location:
    Jackson, MS
    Check the mode actuator by the gas pedal. It has some linkages that adjust the door in the box between defrost-panel-floor. Sometimes they can come apart.

    There is a notched silver dial on it that should rotate as the dash selector is moved. It should rotate smoothly between the three marks at 11, 12 and 1:00.

    [​IMG]

    See last few posts in this thread for better photos...

    http://www.gmt400.com/threads/weird-ac-problem.38966/page-3


    Sent from my iPhone using Tapatalk
     
    GeorgiaMudCow likes this.
  3. GeorgiaMudCow

    GeorgiaMudCow Newbie

    Messages:
    4
    Likes Received:
    3
    Joined:
    Feb 16, 2018
    Location:
    North Florida
    Awesome thanks!
     

Share This Page