Slipping trans after rebuild.

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

BradHanks15

OBS Enthusiast
Joined
Apr 15, 2024
Messages
60
Reaction score
23
Location
Nebraska
Hey guys wanted to get sold advice on what to do here. 4l60e out of a 03 Tahoe. Trans had no 3rd 4th gear before. My dad and I made our first attempt at rebuilding one of these. Didn’t pull apart the valve body or pump. Didn’t replace the Torque converter. Put it back in and now won’t go over 15 in drive. Anymore throttle then it takes to go fast it go straight to redline. Won’t do anything in any other gear. Only D. Reverse seems to work better than forward. Makes 55 psi base. Pressure is about the same in every other gear. Pressure barely moves with throttle. Commanded 1 amp Through .1 and got 55 -80 psi. Goes way past stall speed in d but holds it in reverse. Lmk any other thing I can check. Or any other advice. I don’t mind tearing back into as long as I can fix it the first time. Lmk if you need any more info. Thanks
 

Sean Buick 76

I'm Awesome
Joined
Jan 6, 2024
Messages
1,031
Reaction score
2,210
Location
Edmonton Alberta
Normally the torque converter and cooler are full of metal and clutch shavings after a trans failure so if you didn’t replace or properly flush those two items then that’s a good reason why the fresh trans ate itself.
 

BradHanks15

OBS Enthusiast
Joined
Apr 15, 2024
Messages
60
Reaction score
23
Location
Nebraska
Normally the torque converter and cooler are full of metal and clutch shavings after a trans failure so if you didn’t replace or properly flush those two items then that’s a good reason why the fresh trans ate itself.
I flushed the cooler with some cooler flush. And put the same stuff in the converter. I took some advice on drilling a hole and putting in a drain plug for it. So ran a few qts through after til it looked good. Dk if it was a good idea or not. Just was told they had done that multiple times.
 

NickTransmissions

Supporting Member
Supporting Member
Joined
Aug 16, 2023
Messages
785
Reaction score
1,184
Location
Las Vegas
Hey guys wanted to get sold advice on what to do here. 4l60e out of a 03 Tahoe. Trans had no 3rd 4th gear before. My dad and I made our first attempt at rebuilding one of these. Didn’t pull apart the valve body or pump. Didn’t replace the Torque converter. Put it back in and now won’t go over 15 in drive. Anymore throttle then it takes to go fast it go straight to redline. Won’t do anything in any other gear. Only D. Reverse seems to work better than forward. Makes 55 psi base. Pressure is about the same in every other gear. Pressure barely moves with throttle. Commanded 1 amp Through .1 and got 55 -80 psi. Goes way past stall speed in d but holds it in reverse. Lmk any other thing I can check. Or any other advice. I don’t mind tearing back into as long as I can fix it the first time. Lmk if you need any more info. Thanks
Yank it. Reman the pump; never rebuild a trans without going through the pump and valve body. Machine both pump working surfaces, install new rotor guide and vanes along with a sonnax boost valve kit (4L60E-LB1). Overhaul the valve body; convert the PWM to an on-off using whichever method you prefer.

Pressure test the forward drum - make sure it's not leaking at the base of the shaft where it's pressed into the drum.

If you havent, replace the harness, psma, solenoids and vss.

It sounds like the converter isn’t fully seated into the trans

He would have destroyed the pump immediately upon start up; no movement period.
 
Last edited:
Top