Sputtering and no power

Discussion in 'Feedback, Help and Suggestions' started by John916, Oct 31, 2017.

  1. John916

    John916 Newbie

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jun 21, 2017
    Location:
    Doswell,va
    Hey all, my truck has usually been pretty good to me. I recently drove it across the country and back with no problems. I am not too hard on the truck but within the last week I have raced it at a sand drag and went through some very muddy water holes. Today, when I went to drive it it was fine going down the road 15 miles and on my way back when I got on the gas to get on the interstate it started to sputter and had no power. Anything above 2,800 rpms about in 2nd gear mostly it has no power. I know I have some exhaust leaks but it sounds like a bunch of stuff in my exhaust. Also, when I was checking fluids my transmission fluid was just bubbles on the dipstick kind of high up. I left it in a parking lot and am towing it back tomorrow. Any advice on what to check? Really hoping this isn’t a transmission problem.
     
  2. John916

    John916 Newbie

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jun 21, 2017
    Location:
    Doswell,va
    Anyone? I️ just replaced distributor cap and rotor and wires, spark plugs looked good. Only thing shop could tell me besides they though those might be bad is my fuel pressure would drop to 48


    Sent from my iPhone using Tapatalk
     
  3. Nathaniel2g

    Nathaniel2g Rusty Islander

    Age:
    22
    Messages:
    182
    Likes Received:
    16
    Joined:
    Oct 4, 2015
    Location:
    Prince Edward Island, Canada
    Bubbles in your trans fluid? Sounds like you got water in there some how. I know that I had a similar issue but the truck was missing. Ended up being a crank position sensor. Also, the rattling sound could be blown out catalytic material.
     
  4. John916

    John916 Newbie

    Messages:
    9
    Likes Received:
    0
    Joined:
    Jun 21, 2017
    Location:
    Doswell,va
    Thank you, I’ve had 2 shops tell me now that it’s the fuel pump. I️ replaces I️t in August but it’s still under warranty so I’ll give I️t another try I️ guess


    Sent from my iPhone using Tapatalk
     

Share This Page