Brake Lights Not Working

Discussion in 'Audio + Electronics' started by 97redz71, Mar 20, 2017.

  1. 97redz71

    97redz71 Newbie

    Messages:
    11
    Likes Received:
    0
    Joined:
    Oct 3, 2014
    I have a 97 K1500. When I put my foot on the brakes, the two tail lights do not light up, but my 3rd brake light does. The blinkers, tail lights, and turn signals all work fine. I checked the bulbs and the fuses and they are all fine. Would it be the switch? I am just a little confused because the 3rd brake light is still working, so I am not sure what's going on.
    Any advice is much appreciated.
    Thanks
     
  2. magimerlin

    magimerlin I'm Awesome

    Messages:
    1,729
    Likes Received:
    186
    Joined:
    May 27, 2013
    Location:
    Flatonia, Texas
    Yes. It could still be the switch...

    Sent from my SAMSUNG-SM-G891A using Tapatalk
     
  3. 97redz71

    97redz71 Newbie

    Messages:
    11
    Likes Received:
    0
    Joined:
    Oct 3, 2014
    Is the switch removal quite a task?
     
  4. magimerlin

    magimerlin I'm Awesome

    Messages:
    1,729
    Likes Received:
    186
    Joined:
    May 27, 2013
    Location:
    Flatonia, Texas
    Nope.... 10 minute job, if that....

    Sent from my SAMSUNG-SM-G891A using Tapatalk
     
  5. Bob L

    Bob L Supporting Member

    Messages:
    609
    Likes Received:
    276
    Joined:
    Oct 11, 2016
    Location:
    Centerville , Ma.
    This might help

     

Share This Page