Sle-z_90
Reaction score
9

Latest activity Postings About

    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      That would be obvious, or no?
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      I pulled the valve covers today. I saw the heads were 14102193 which the internet says were factory heads for 350 TBI engines. So that...
      • 5E9FED9F-F2E0-4F4C-9929-F83884CE69A8.jpeg
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      Thank you again. I’ll do that next then.
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      Completed my compression test today. 3 cylinders were well outside the expected range. Two were zero and one read about 35ish...
    • Sle-z_90
      Sle-z_90 reacted to PlayingWithTBI's post in the thread Running terribly with Like Like.
      Yes, your lifter preload may be too tight, a valve may be stuck open, or the piston isn't all there. Hopefully it's the 1st one ;)
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      Thank you for the this response. I’ll complete checking compression then start investing these if I don’t have a different result later.
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      Also, the ignition timing is almost certainly off. I assume this doesn’t matter since I removed the fuses for the fuel pump and...
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      Started replacing plugs, checking spark, and checking cylinder compression. I got no compression reading on cylinder 3. I got a reading...
    • Sle-z_90
      Sle-z_90 replied to the thread anyone else in maryland ?.
      That’s a nice truck
    • Sle-z_90
      Sle-z_90 reacted to DDTurbo's post in the thread anyone else in maryland ? with Like Like.
      I know a guy in Gaithersburg. Has this ex Air Force pickup. powered by diesel.
    • Sle-z_90
      Sle-z_90 replied to the thread anyone else in maryland ?.
      Old thread but I’m in Anne Arundel. Just picked up a 90 rcsb. Trying to get it running right. Hopefully y’all will see me cruising it on...
    • Sle-z_90
      Sle-z_90 reacted to victor II's post in the thread Running terribly with Like Like.
      Have you checked the distributor cap, rotor, wires and plugs? Also, run some Seafoam through the fuel system to clean the injectors...
    • Sle-z_90
      Sle-z_90 reacted to Schurkey's post in the thread Running terribly with Like Like.
      Fresh, CORRECT plugs, test the plug wires, verify cap and rotor. Get the timing set. Looks more like oil fouling than fuel fouling to...
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      So I looked it up again. It’s either carbon fouled, meaning it’s likely too rich. Alternatively, they’re oil fouled meaning I have...
    • Sle-z_90
      Sle-z_90 replied to the thread Running terribly.
      This morning I pulled the Egr valve. It held a vacuum and didn’t stick or anything. The metal gasket was a little rough so I replaced it...
  • Loading…
  • Loading…
Top