HVAC actuator?

Discussion in 'Street Chat / Timeslips' started by 1994, May 10, 2017.

  1. 1994

    1994 I'm Awesome

    Age:
    23
    Messages:
    175
    Likes Received:
    5
    Joined:
    Feb 25, 2015
    Anyone have similar issue here, my 1996 Chevy Silverado C1500 HVAC is not working as it should be.
    It blows hot & cold, blend doors will work to feet and defrost setting, but when I move it to feet/head or just head no air gets out of any of the vents on the dash.

    It only comes out from bottom or the top.

    Is this the mode actuator? Or is it something else?
    I tried cleaning debris out of the A/C blower filter but there was nothing in there, also have a new HVAC panel so I know it isnt that.
    Help :D
     
  2. delta_p

    delta_p Newbie

    Messages:
    28
    Likes Received:
    13
    Joined:
    Jan 8, 2017
    Location:
    Alabama
    The mode actuator down by right foot driver is the one that moves the flaps to head, feet, and defrost. sometimes the gear in the actuator breaks which could affect the trim pot setting limiting the range of motion. crawl in there on your back and turn on the blower then operate the mode switch. you basically see the full range of motion from marks in the photo. It could also be the flaps or linkages are bound so if you take it off, you might want to see if you can maneuver the shaft and linkages full range. mode.jpg
     
  3. 1994

    1994 I'm Awesome

    Age:
    23
    Messages:
    175
    Likes Received:
    5
    Joined:
    Feb 25, 2015
    I was going to try swapping the mode actuator with the one out of my '99 because I knew it worked. While unscrewing that one I noticed it had an extra "mechanism" that connected further up in there.
    On closer look in my '96, that mechanism was completely unlatched. Decided both the mode actuators were working fine, and screwed around for about 40 minutes trying to link the mechanism back onto the small rod coming out of the dash. After much headache (previous owner seems to have installed an absolute FUCKTON of shit under my dash, almost all of it in my way, no clue what any of it does/is)
    Took some large rectangular metal box with a plugin out from under there and was able to reach finally and plug the mechanism back on the rod. Tested it and I FINALLY have A/C blowing out of all of the front vents.

    Thanks for the reply...im glad it ended up being something stupid. I figure whoever installed that metal box thing up there probably knocked the mechanism off its rod somehow. It was pretty tight up there to get that f***** box out of there, and back in there.
     

Share This Page