Chevy C1500 1995 4l60e trouble

Disclaimer: Links on this page pointing to Amazon, eBay and other sites may include affiliate code. If you click them and make a purchase, we may earn a small commission.

Cast_iron

Newbie
Joined
Apr 2, 2024
Messages
3
Reaction score
0
Location
Az
I have a gmt400 and I’m currently having transmission problems I drive for a bit and my truck will shift fine 1-2 is sort of rough but 2-3 will take a while to disengage from 2nd then engage into 3 it will do the same thing as I down shift from 3-2 and afterwards my truck jumps into limp mode does anyone know what is going on is it’s a leak or could it be a bad solenoid I have no check engine light and I can’t get my hands on a obd1 scanner so I’m absolutely lost right now I also would like to know what transmissions I would be able to use so my truck will run smoothly.
 

NickTransmissions

Supporting Member
Supporting Member
Joined
Aug 16, 2023
Messages
646
Reaction score
1,049
Location
Las Vegas
I have a gmt400 and I’m currently having transmission problems I drive for a bit and my truck will shift fine 1-2 is sort of rough but 2-3 will take a while to disengage from 2nd then engage into 3 it will do the same thing as I down shift from 3-2 and afterwards my truck jumps into limp mode does anyone know what is going on is it’s a leak or could it be a bad solenoid I have no check engine light and I can’t get my hands on a obd1 scanner so I’m absolutely lost right now I also would like to know what transmissions I would be able to use so my truck will run smoothly.
Check your vehicle speed sensor in the extension housing. If it's intermittently failing, you will be neutral or severly flare shift from 2-3. If it's not the speed sensor, the 3-4 clutch is prob failing. Over 90% of 4L60Es that i have rebuilt over the years ended up in my shop for that reason.

Limp mode is 3rd gear and reverse in 4L60Es.

Quick check: unplug the large case connector on the pass side of the trans, start it up and put it in drive. If it moves, the 3-4 pack is likely ok.
 

Cast_iron

Newbie
Joined
Apr 2, 2024
Messages
3
Reaction score
0
Location
Az
I did all of that nothing changed besides my speedometer my fluids are solid but when I pulled out one of my fuses it was popped so I replaced it drove my truck for a bit no issue until about 15 minutes into driving 2-3 was super rough and my rpm’s skyrocketed anyone got any other ideas?
 

NickTransmissions

Supporting Member
Supporting Member
Joined
Aug 16, 2023
Messages
646
Reaction score
1,049
Location
Las Vegas
I did all of that nothing changed besides my speedometer my fluids are solid but when I pulled out one of my fuses it was popped so I replaced it drove my truck for a bit no issue until about 15 minutes into driving 2-3 was super rough and my rpm’s skyrocketed anyone got any other ideas?
From what you're saying here, sounds like you have one or more shorts in your electrical system and it's directly impacting the transmission. So have to find it or them and fix.
 

1997

I'm Awesome
Joined
Aug 2, 2013
Messages
1,141
Reaction score
2,122
Location
B.C. CDN
Cast, OBD1 can set codes without the check engine light coming on.
You don't need a code reader to check, google check codes obd1 to find procedure.
 
Top