Strange Fuel Gauge Behavior, '97 C1500

df2x4

Domestics only.
Staff member
Super Moderator
Joined
Mar 1, 2012
Messages
9,052
Reaction score
7,705
Location
Missouri
So yesterday I was getting in my red truck ('97 C1500) to go somewhere and I noticed something odd. I filled the tank up the night before, but when I started the truck the fuel gauge read completely empty sitting in my driveway. I knew it had gas, so I pulled out of the driveway and started moving. The gauge slowly started creeping up, and by the time I made it to my destination (5-10min) it was reading full again. When I started the truck to go home the gauge behaved normally.

Has anyone experienced this before? If so what was the cause? I'm leaning towards the sensor in the tank rather than a wiring or cluster issue, as there is no erratic gauge movement. It was a very slow and gradual thing.
 

1997

I'm Awesome
Joined
Aug 2, 2013
Messages
699
Reaction score
1,054
Location
B C
have the exact same issue with my 97 and fuel gauge, sorry no help on fix but its on my to do list.
It gradually got worse and now pretty much stays on E.
Going to add a bottle of techron see what happens, but it seems to have disappeared up here.
Some people report that fixed the issue...
 

VIKING_MECHANIC

OBS obsessed Viking
Joined
Jul 12, 2020
Messages
371
Reaction score
583
Location
Arkansas
I have something similar happening on my 97 C1500. With the key on or engine running, the gauge will how ~5 gallons less then what I actually have. Turn it off and it goes up about 5 marks. I'm thinking it's the sending unit.

But since Kenny mentioned it, I should probably check the ground strap on the tank....
 

1997

I'm Awesome
Joined
Aug 2, 2013
Messages
699
Reaction score
1,054
Location
B C
just re-did grounds for fuel tank since i replaced the rear brake lines and had to drop the tank.
tested sender etc while it was out and it appears to be gauge itself.
jeeze, why did they go to stepper motors for gauges?
old school resistor worked just fine .....
 

df2x4

Domestics only.
Staff member
Super Moderator
Joined
Mar 1, 2012
Messages
9,052
Reaction score
7,705
Location
Missouri
Mine has been working fine since I made this thread... Knock on wood...
 
Top