chapmangd

Newbie
Joined
Sep 14, 2021
Messages
6
Reaction score
8
Location
Texas
If this is the wrong place to post, I'm sorry I can never figure out any of these forums. So I have a 1998 vortec 5.7, and randomly about once a month, it will crank and turn over but then instantly kill itself. (I have a video but I can't attach it, If you want me to add you on snap, facebook, insta whatever so I can send it too ya let me know.) If I walk away and let it sit for awhile, it cranks right up. I've disconnected the battery, cycled the key, held the pedal down for 10 seconds like the manual says, but nothing works except letting it sit. I believe the fuel pump was replaced along with the fuel filter, but I don't know about the fuel pressure regulator. I took it too a shop and they couldn't duplicate the problem but said its fuel pressure was fine. Has anyone encountered this before and found the the fix? Am I looking in the right place or is this a wiring issue to a sensor?
 
Last edited:

df2x4

Domestics only.
Staff member
Super Moderator
Joined
Mar 1, 2012
Messages
8,837
Reaction score
7,128
Location
Missouri
So I have a 1998 vortec 5.3, and randomly about once a month, it will crank and turn over but then instantly kill itself.

Being a '98, this really sounds like a PassLock issue. Do you get a security light on the dash when this happens?

EDIT - Also, you mean 5.0 (305) right? The 5.3L is a newer GMT800 engine.
 

chapmangd

Newbie
Joined
Sep 14, 2021
Messages
6
Reaction score
8
Location
Texas
Being a '98, this really sounds like a PassLock issue. Do you get a security light on the dash when this happens?

EDIT - Also, you mean 5.0 (305) right? The 5.3L is a newer GMT800 engine.
Sorry it’s got the 5.7 350. I’ll have to pay attention next time. In the video I have all the dummy lights are on, but I can’t make out if the security light is, is it on the left hand side center? Say it is this issue how do I fix it?
 

df2x4

Domestics only.
Staff member
Super Moderator
Joined
Mar 1, 2012
Messages
8,837
Reaction score
7,128
Location
Missouri
Say it is this issue how do I fix it?

IMO the best way is to have PassLock disabled in the PCM tune. Anyone with HPTuners can do this, it's just unchecking a box. Prices seem to range from $1-300 or so. Black Bear Performance can do it via mail if you don't have any local shops with HPTuners.

There are other cheaper ways to fix it, but they're just fooling the system into working. If you disable it in the tune then the PCM will never even look for a signal from the PassLock module again.
 

chapmangd

Newbie
Joined
Sep 14, 2021
Messages
6
Reaction score
8
Location
Texas
Upper right corner, Security light should come on with ignition on (engine off) and turn off after a few seconds.

You must be registered for see images attach
In the video I can see it on, but so are all the other lights, but honestly I really can’t tell. It’s happened like 5 times and I wasn’t paying attention to lights. For the sake of a fix, say it is on?
 

chapmangd

Newbie
Joined
Sep 14, 2021
Messages
6
Reaction score
8
Location
Texas
IMO the best way is to have PassLock disabled in the PCM tune. Anyone with HPTuners can do this, it's just unchecking a box. Prices seem to range from $1-300 or so. Black Bear Performance can do it via mail if you don't have any local shops with HPTuners.

There are other cheaper ways to fix it, but they're just fooling the system into working. If you disable it in the tune then the PCM will never even look for a signal from the PassLock module again.
Thanks man, I don’t have any tuner computers, but I’ll hit up the shop and see what the cost will be and go ahead and do it!
 
Top