Rear Exterior Light Issue

Discussion in 'Paint / Body / Detailing' started by 97C1500TJ, May 22, 2020.

  1. 97C1500TJ

    97C1500TJ I'm Awesome

    Messages:
    112
    Likes Received:
    200
    Joined:
    May 22, 2020
    Location:
    Southern US
    Hello,

    I hope this is in the right section as this is my first thread. I am having weird issues with my taillights on my 1997 C1500 and have no idea where to go next. I’ve checked all fuses under the hood and by the dash. I have not checked the relays nor do I know how to. I originally thought it was just the left side socket as my blinker was my only issue. Now it’s progressed to the following:

    Headlights OFF: Reverse lights do not come on. Instead my brake lights come on when I’m in reverse. Left brake light and blinker do not work.

    Headlights ON: No taillights, brake lights, or reverse lights. Right blinker is brighter than the left.

    Any help is appreciated. Thanks
     
    HotWheelsBurban likes this.
  2. someotherguy

    someotherguy I'm Awesome

    Messages:
    4,964
    Likes Received:
    2,336
    Joined:
    Sep 28, 2013
    Location:
    Houston TX
    Probably a bad ground. It could be one or both of the taillight circuit boards are bad (fairly common once they get old) or simply the ground wire for the rear lamp harness is bad. If you have a trailer harness attached, disconnect it for now until you have the lights working correctly.

    If you look at the end of the driver's side frame rail where the bumper bracket bolts up, you'll find a disconnect for the rear light harness. The rear section will have a ground wire going to either the frame, or one of the crossmembers near the rear of the truck. Be sure it's attached and in good shape.

    You can disconnect the rear lamp harness and test with a simple test light right there where the harness comes from the front of the truck. Ground your test light right there at the back of the truck and then probe the connector. Yellow is left turn signal/brake light, dark green is right turn signal/brake light, light green is reverse lights, brown is taillights/tag lights.

    Richard
     
    HotWheelsBurban likes this.
  3. 97C1500TJ

    97C1500TJ I'm Awesome

    Messages:
    112
    Likes Received:
    200
    Joined:
    May 22, 2020
    Location:
    Southern US
    Thanks. I will give that a try. I did replace one of the taillight circuit boards already and the problem persisted so I went back to my original. Maybe it could be the other one.
     
    HotWheelsBurban likes this.
  4. 97C1500TJ

    97C1500TJ I'm Awesome

    Messages:
    112
    Likes Received:
    200
    Joined:
    May 22, 2020
    Location:
    Southern US
    It might help if my taillight ground wasn’t corroded off like my trailer lights ground. Thanks for the help.

    C605094F-7209-4AE1-9AC6-6D1E256767D8.jpeg
     
    HotWheelsBurban and someotherguy like this.
  5. Chevy797

    Chevy797 Newbie

    Messages:
    2
    Likes Received:
    3
    Joined:
    Sep 4, 2020
    Location:
    California
    Did this fix your problem im having a similar problem but can't track it down exactly.
     
    HotWheelsBurban and 97C1500TJ like this.
  6. 97C1500TJ

    97C1500TJ I'm Awesome

    Messages:
    112
    Likes Received:
    200
    Joined:
    May 22, 2020
    Location:
    Southern US
    Yes it did. I do have a problem currently where if it rains, my left blinker goes out until it dries. I guess I should try some dielectric grease or something.
     
    HotWheelsBurban and SUBURBAN5 like this.
  7. Chevy797

    Chevy797 Newbie

    Messages:
    2
    Likes Received:
    3
    Joined:
    Sep 4, 2020
    Location:
    California
    Ok im gnna try it to reconnect my ground again. Right now I'm im having an issue with both of my reverse lights flashing with my right blinker and also coming on everytime I hit my brake i just removed the brake controller and trailer wires but still same problem.
     
    97C1500TJ likes this.

Share This Page