Radio is being stupid......

Discussion in 'Audio + Electronics' started by kenh, Jan 13, 2021.

  1. kenh

    kenh I'm Awesome

    Messages:
    283
    Likes Received:
    347
    Joined:
    May 22, 2020
    Location:
    rockwell, ia
    I guess it is 30 years old. This morning all I can do is increase the volume. Occasionally I can get the volume down to a reasonable level but ..... I guess it's time to bite the bullet and get something new.:(:)

    Ken
     
    HotWheelsBurban and SUBURBAN5 like this.
  2. SUBURBAN5

    SUBURBAN5 I'm Awesome

    Messages:
    2,621
    Likes Received:
    4,094
    Joined:
    Jul 18, 2020
    Location:
    Houston
    you can find some used ones maybe. Otherwise I would get aftermarket. There not that bad. I actually like having bluetooth for phone calls. Makes her feel new. Btw I got a plain radio nothing fancy. I'm not for the touch screens.
     
    kenh and HotWheelsBurban like this.
  3. HotWheelsBurban

    HotWheelsBurban Burbs are great!

    Messages:
    1,857
    Likes Received:
    2,589
    Joined:
    Sep 18, 2019
    Location:
    Stafford, Texas
    Both my 99 Burbs have had radio and CD/tape player problems. Took the units out of the first Burb and had a Delco trained radio tech work on them. He's rebuilt several of the 80s ETR radio decks for us. He said basically what happens in car radios is that the soldered connections rattle loose after several years of being bounced around in daily driving. But after so many years, parts to repair these, and the expertise to do so, are harder to find. He fixed the units for the old Burb, and they worked great for the rest of the truck's life. Took em out and they're going in the current Burb whenever I do all the other dashboard work. Not messing with 22 year old plastic when it's cold LOL.
     
    F4U-1A and SUBURBAN5 like this.
  4. Nad_Yvalhosert

    Nad_Yvalhosert I'm Awesome

    Messages:
    139
    Likes Received:
    190
    Joined:
    Oct 11, 2016
    Location:
    Rochester, NY
    There's been a listing on ebay where the guy takes yours, refurbishes it and adds a 3.5mm input jack. Reasonable prices and many positive reviews. Just an option...
     
  5. DerekTheGreat

    DerekTheGreat I'm Awesome

    Messages:
    979
    Likes Received:
    605
    Joined:
    May 23, 2016
    Location:
    Michigan
    Or just go hunt in a treasure yard for another CDM. That's all that usually goes bad. Pins get corroded and then it goes wonky.

    I decided to upgrade from the base tape deck to the one with a graphic equalizer. AWAL98K or something like that made a great thread about which CDM's to look for. Some have upgraded heatsinks and a little more output, in addition to being more stable with 4 ohm loads. Just pop the cover off, inspect the pins for corrosion and snag the first you find which is clean.
     
    HotWheelsBurban and SUBURBAN5 like this.
  6. AK49BWL

    AK49BWL GMT400 Forever!

    Messages:
    843
    Likes Received:
    1,230
    Joined:
    Mar 21, 2015
    Location:
    Longview, TX
    AWAL98K? That's a new one :rofl:

    If it's cold where you are, chances are the buttons are just sticking or not making contact. Mine in my 93 would stick so if I tried turning up the volume a little, it wouldn't let go and CONTINUED raising the volume until I beat it into submission lol. You could take apart the head and use some isopropyl alcohol on the contacts, that cured mine.
     
  7. Jglew82

    Jglew82 I fix stuff

    Messages:
    414
    Likes Received:
    377
    Joined:
    Feb 9, 2018
    Location:
    Texas
    Mine did that about 15 years ago. Couple rounds of "percussive maintenance" and it never did it again. Haha
     
    HotWheelsBurban and SUBURBAN5 like this.
  8. Eveready

    Eveready I'm Awesome

    Messages:
    1,024
    Likes Received:
    943
    Joined:
    Nov 29, 2017
    Location:
    North Carolina
    A neighbor of mine had the same problem. (the factory radio in mine was defunct when I bought the truck so it sits on a shelf)

    I fixed his for him by spraying the control with DeOxit contact cleaner. It works really well and will usually fix this sort of problem. His would not change stations except the buttons and the volume was acting just like yours. Sprayed it heavily and it fixed it right up.
     
    HotWheelsBurban and kenh like this.
  9. kenh

    kenh I'm Awesome

    Messages:
    283
    Likes Received:
    347
    Joined:
    May 22, 2020
    Location:
    rockwell, ia
    It does seem to be a cold problem. After a hour long trip and the interior was nice and toasty warm everything worked OK. Mine does have the equalizer option (no tape deck) which seems to work just fine.

    Ken
     
  10. AK49BWL

    AK49BWL GMT400 Forever!

    Messages:
    843
    Likes Received:
    1,230
    Joined:
    Mar 21, 2015
    Location:
    Longview, TX
    Mine was always just the volume control, everything else generally worked great.
     
    HotWheelsBurban and SUBURBAN5 like this.

Share This Page