P0106 after engine install

redneckz71

Newbie
Joined
Mar 27, 2015
Messages
12
Reaction score
0
Location
las vegas, nv
Working on my 96 k1500 with the l31. Blew an oil cooler line and locked up my old engine so got a cheap replacement from a 97 tahoe to hold me over until i get my ls3 built. Fired right up has a nast exhaust leak after the cats( picked up a new gasket that ill replace tomorrow) i put all my old stuff on the used motor aside from the cap/rotor, knock sensor and crank sensor. Ill be checking for vacuum leaks in the morning and swapping out for my old cap and rotor. The truck isnt smoking but seems to be running only on a few cylinders. The new motor came with the updated fuel injector also. Im getting the map code p0106 could it be lower intake gaskets or possibly a burt valve or something in the valve train. My old motor ran like a champ so just a little stumped by what it could be. The guy i bought the motor from said he ran it and it sounded fine but it was after he already pulled the y pipe. Thank you in advance
 

skylark

I'm Awesome
Joined
Nov 15, 2011
Messages
6,754
Reaction score
4,459
Location
Grants Pass, OR
If you separated the upper and lower intake then check around the injector harness. That oval o ring can be a pain.
 

badazzbulldog

I'm Awesome
Joined
Oct 13, 2010
Messages
2,978
Reaction score
76
Location
medway,ma
i realize he got that part those are some suggestions of what to check,and he sent some rep points my way for posting that link to him.always start with the simple checks
 

redneckz71

Newbie
Joined
Mar 27, 2015
Messages
12
Reaction score
0
Location
las vegas, nv
Checked vacuum leaks, then figured id put a 5 dollar bill over the exhaust tip, tried to suck it back in pulled the valve covers and #8 had a broken spring along with a bent valve. Thanks for the imput. should have just gotten a wrecking yard motor than trusting someon
You must be registered for see images attach
You must be registered for see images attach
e
 
Top