no power to injectors after swap (5.7 vortec)

Discussion in 'Engine Performance + Maintenance' started by Turbokat, Aug 8, 2018.

  1. east302

    east302 I'm Awesome

    Messages:
    1,168
    Likes Received:
    332
    Joined:
    Oct 4, 2013
    Location:
    Jackson, MS
    Bleeping hell, that looks like fun.

    The green/white wire in question, is that going to the connector through the firewall under the brake booster?


    Sent from my iPhone using Tapatalk
     
  2. east302

    east302 I'm Awesome

    Messages:
    1,168
    Likes Received:
    332
    Joined:
    Oct 4, 2013
    Location:
    Jackson, MS
    I reread your post, saw you said it’s coming from the black connector. Here are all four, looks like you might need it. These are all for a 1998, by the way.

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  3. Steve A

    Steve A OBS Enthusiast

    Messages:
    92
    Likes Received:
    15
    Joined:
    Jun 3, 2015
    Location:
    Central Arkansas
    Looks like the wires that have the tan and purple wires spliced in may be the injector control wires, may be where they were cut and the LPG ECU was tied in. Check the original wires they are spliced in to for matching colors. Check for continuity between PCM connector and spider connector with matching color (?) wires reconnected. As for the wire from the BLACK connector follow it back to the plug to see what pin it is attached to, that will shorten your search a little maybe.
     

Share This Page