Low idle on hot start

Discussion in 'Engine Performance + Maintenance' started by 94burbk1500, Aug 8, 2018.

  1. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    404
    Likes Received:
    123
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    When it is hot outside, and the engine is hot, the truck idles really low and almost dies on startup. This does not happen in the morning when it is cool and the truck has been sitting. If I give it some gas it comes back to life and idles fine. The truck runs fine aside from this, no codes, any ideas? 1994 burban, stock TBI 5.7L
     
  2. Jack Schneider

    Jack Schneider OBS Enthusiast

    Messages:
    88
    Likes Received:
    16
    Joined:
    Jun 5, 2018
    Location:
    Nebraska
    Did you clean the I. A. C. ?
     
  3. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    404
    Likes Received:
    123
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    I have not. Should i just remove it and hit it with some carb cleaner?
     
  4. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    404
    Likes Received:
    123
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    Slight update, engine temp doesn't seem to be a factor, just ambient temp, I just had it happen when the engine was cool. I'll see about cleaning the IAC tonight or tomorrow, whenever I get a chance.
     
  5. Jack Schneider

    Jack Schneider OBS Enthusiast

    Messages:
    88
    Likes Received:
    16
    Joined:
    Jun 5, 2018
    Location:
    Nebraska
    Yep!
     
  6. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    404
    Likes Received:
    123
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    Cool, thanks!
     

Share This Page