How much fuel pressure for a 5.7 vortec?

Fast 95

I'm Awesome
Joined
Dec 14, 2009
Messages
204
Reaction score
3
How much fuel pressure should i have for a 96 5.7 vortec?
 

6chevy9

I'm Awesome
Joined
Jan 14, 2010
Messages
1,243
Reaction score
26
Location
pinckney mi
i belive i read somthing that said 60-65 psi but i could be wrong ill take a look. i think i saw that on GMFS. if i find it ill post a link or the info
 

Fast 95

I'm Awesome
Joined
Dec 14, 2009
Messages
204
Reaction score
3
That would be great, i dont want to spend $100 if i dont have to.
 

6chevy9

I'm Awesome
Joined
Jan 14, 2010
Messages
1,243
Reaction score
26
Location
pinckney mi
yes that was correct as far as everything i have read

copy and paste from another site

Your reading was done at idle. GM lists no fuel specs with the engine running. Below is the GM test procedure and spec:

FUEL PRESSURE



Ignition "OFF" for 10 Seconds.
With ignition "ON," engine "OFF" and fuel pump running, pressure should be 415-455 kPa (60-66 psi).
 

Fast 95

I'm Awesome
Joined
Dec 14, 2009
Messages
204
Reaction score
3
I'm only getting 57 psi with the key on engine off, and it drops to 50 psi while running.
 

Mike

I'm Awesome
Joined
Dec 2, 2009
Messages
1,585
Reaction score
406
Location
Mass.
You should be ok with that, no matter what your pressure do that engine will be starved for fuel until you switch to a real injection system.
 

6chevy9

I'm Awesome
Joined
Jan 14, 2010
Messages
1,243
Reaction score
26
Location
pinckney mi
i also dont see that being your miss fire problem, unless one injector is pluged or somthing but you said you replace/ cleaned them i belive already so i dont see that being a cause.
 

MIHELA

1-5-6-3-4-2-7-8
Joined
Dec 9, 2009
Messages
1,325
Reaction score
1,399
Location
Sioux Falls, SD
57 is not enough to overcome the poppet nozzles on the Vortec. That is definitely your problem.
 

Fast 95

I'm Awesome
Joined
Dec 14, 2009
Messages
204
Reaction score
3
57 is not enough to overcome the poppet nozzles on the Vortec. That is definitely your problem.
Its 57 with the motor not running, once started its 50 psi, and i do have the upgraded spider injectors as well.
 
Top