4L60E No OD

Discussion in 'Transmissions' started by deven bullis, Jan 13, 2020 at 3:35 PM.

  1. deven bullis

    deven bullis OBS Enthusiast

    Messages:
    80
    Likes Received:
    21
    Joined:
    Apr 14, 2016
    Location:
    Greensboro, North Carolina
    My 4l60E wont shift into OD/cruise disabled when my ABS light is on, but the problem is I have no codes for the abs system. When the ABS light is off OD and cruise control works, usually when the truck is cold, if its warm the ABS light turns on, leading me to think a bad abs module or wire somewhere in the system. I haven't seen a post where someone has had this problem before so I'm pretty lost.
     
  2. Roadrunner

    Roadrunner Newbie

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Location:
    NM
    Check the wire loom going to the transmission connector and see if its melted. Where it crosses over the back of the trans. If its melted the wires are probably melted too, it's the first sign of 3-4 going out soon. It could be abs is tied to output speed sensor but I dont know for sure.

    Another possibility with the abs system is bad solder joints on the circuit board where the heavy gauge power wires come in. It's a pretty easy fix if your handy with a soldering iron. I've run into more than a few like this.
     
    deven bullis likes this.
  3. deven bullis

    deven bullis OBS Enthusiast

    Messages:
    80
    Likes Received:
    21
    Joined:
    Apr 14, 2016
    Location:
    Greensboro, North Carolina
    Are the bad solder joints located by the transmission or by the ABS box?
     
  4. Roadrunner

    Roadrunner Newbie

    Messages:
    6
    Likes Received:
    2
    Joined:
    Tuesday
    Location:
    NM
    There in the abs box under the torx cover screws. It's a bit of a pain to get the cover off. The main issue is all this stuff is done in silver solder which has issues with time, vibration, and resistance do to its crystallized structure.

    When it's cold it contracts and makes good contact but once warm the connection goes. It doesnt explain why od is going off at the same time though and why I suspect the wiring harness at the trans.
     
    deven bullis likes this.
  5. Supercharged111

    Supercharged111 I'm Awesome

    Age:
    37
    Messages:
    4,043
    Likes Received:
    1,644
    Joined:
    Aug 20, 2015
    Are you sure it's 4th not engaging and not the TCC refusing to lock?
     
    deven bullis likes this.
  6. deven bullis

    deven bullis OBS Enthusiast

    Messages:
    80
    Likes Received:
    21
    Joined:
    Apr 14, 2016
    Location:
    Greensboro, North Carolina
    I'm not really sure how to know if the Tcc is refusing to lock or not, when the ABS light is on it feels like i put the selector in 3rd and acts like there is no 4th.
     
  7. ima93chevyguy

    ima93chevyguy Zip-Tie Mechanic

    Messages:
    317
    Likes Received:
    229
    Joined:
    Mar 28, 2017
    Location:
    Mississippi
    Check your brake light switch, mine wouldn't stay in OD then it went out and wouldn't lock at all.

    Replaced the switch and all was good
     
  8. deven bullis

    deven bullis OBS Enthusiast

    Messages:
    80
    Likes Received:
    21
    Joined:
    Apr 14, 2016
    Location:
    Greensboro, North Carolina
    I did have a SES light on months ago for “Brake Switch Circuit B Low” but I haven’t had a problem with that switch. Is the brake switch somehow tied in with the ABS system?


    Sent from my iPhone using Tapatalk
     

Share This Page