2000 K3500 4x4 CC DRW

Discussion in 'Member Trucks' started by cool_as_crap, Apr 21, 2016.

  1. Mangonesailor

    Mangonesailor I'm Awesome

    Messages:
    566
    Likes Received:
    245
    Joined:
    Apr 19, 2014
    Location:
    Triad, NC
    You can try this:
    Pull the ECU fuse, turn the key on several times to discharge any capacitors in the ECU.
    Wait about 5min.
    Put the ECU fuse back in, turn the key to on, and WAIT for about 15sec. THEN plug up your cable and initialize a file transfer.

    I got that once after trying to download a tune in a carwash entrance. Care moved out in front of me and I clicked "stop" since there were cars behind me and there was 0 progress made on downloading.

    A good 30min of cursing myself later, I tried the above. Worked. Make sure you give the ECU 5-10 sec to actually boot up before trying to connect to it btw.
     
    Christian Steffen likes this.
  2. cool_as_crap

    cool_as_crap I'm Awesome

    Messages:
    433
    Likes Received:
    159
    Joined:
    Jul 18, 2014
    Location:
    El Dorado County
    I'll try that, i think its the interface though.
    Neither of my laptops see it correctly in device manager. One shows it as an unknown device, the other doesn't show it at all.
    Un-install/re-install drivers does nothing.

    I don't know much about tuning, but I know A LOT about computers :Big Laugh:

    I've been working with their support at the blazing speed of 1 email/day. I'm about ready to order a black bear tune. The shitty thing is the truck ran decently with the black box, but since putting the 411 in I don't have confidence it won't leave stranded somewhere.
     
  3. Christian Steffen

    Christian Steffen I'm Awesome

    Messages:
    896
    Likes Received:
    234
    Joined:
    May 31, 2016
    Location:
    Yankton, SD
    That is quite unfortunate they're being slow to help.. hopefully you can get it sorted out. Hang in there, the 0411 is worth it, especially since you're so close to having the tuning capability.
     
  4. BNielsen

    BNielsen I'm Awesome

    Messages:
    640
    Likes Received:
    401
    Joined:
    Sep 6, 2018
    Location:
    North Carolina
    As someone else who had issues with the 0411, I feel your pain, but like Christian said it's worth it.
    I'm debating on HPTuners or EFILive for my truck, or taking it and having it dyno-tuned.
     
    Christian Steffen likes this.
  5. Mangonesailor

    Mangonesailor I'm Awesome

    Messages:
    566
    Likes Received:
    245
    Joined:
    Apr 19, 2014
    Location:
    Triad, NC
    So, you DID install both the A and B driver for the interface? Or does the MPVI No. 2 not have that need?

    Under power options, you don't have any options selected to allow the USB port to sleep or cut any power, do you? Running win 7? 8? 10? Try a different USB cable too?
     
    Christian Steffen likes this.
  6. cool_as_crap

    cool_as_crap I'm Awesome

    Messages:
    433
    Likes Received:
    159
    Joined:
    Jul 18, 2014
    Location:
    El Dorado County
    Apparently I messed up my credits in trying to edit Christian's tune first, then trying to write to my vehicle.
    I'm not sure what I licensed, but the dude said I need to license my pcm first, then copy/pasta values from Christian's tune to mine, unless I want to license his truck too, then im out another 2 credits.
    I'll try again in a few hours.
     
  7. Mangonesailor

    Mangonesailor I'm Awesome

    Messages:
    566
    Likes Received:
    245
    Joined:
    Apr 19, 2014
    Location:
    Triad, NC
    Yes, you have to pull your tune out, edit it to apply the license (pick something, and then change it back if you want), then you can copy/paste FROM another tune to the tune you pulled out, then download it back to your PCM.
     
    Christian Steffen likes this.
  8. cool_as_crap

    cool_as_crap I'm Awesome

    Messages:
    433
    Likes Received:
    159
    Joined:
    Jul 18, 2014
    Location:
    El Dorado County
    Yeah, figured that out yesterday and I was able to copy most of Christian's tune and write to my PCM, the truck starts and runs a bit better now :D
    Though to my credit I am still having problems with my interface. If I leave it in the garage and try using it in the afternoon when its hot, it doesn't connect. If I throw it in the refrigerator and try again it works. They are going to help me out but at least i know my laptop works and my truck is running better now.

    Once I get a replacement interface I'll start using scanner and try fine tuning, I'm looking forward to learning how to do that.
     
    Christian Steffen likes this.

Share This Page