1997 K2500 ABS activates on first stop after start-up

Discussion in 'Axles + Brakes' started by slovcan, Nov 27, 2020.

  1. slovcan

    slovcan Newbie

    Messages:
    32
    Likes Received:
    34
    Joined:
    Nov 6, 2020
    Location:
    Centreville, Nova Scotia
    Thanks man. I will check it out with the seller (maker in this case) to see if they will send it north and the price of one for the 8-lug like mine.

    Cheers,
    Glenn
     
    HotWheelsBurban likes this.
  2. Ehall8702

    Ehall8702 I'm Awesome

    Messages:
    287
    Likes Received:
    220
    Joined:
    Sep 25, 2019
    Location:
    UP Michigan
    I actually go to Detroit axle website directly , get proper part number and then put that part number into eBay, don't know why but detroit parts are cheaper on eBay than thier site, and it's the actual company selling them on eBay?? Not trying to harp on it just sharing my experience and I'm a cheap sob so I'm always looking for quality stuff as cheap as possible !
     
    HotWheelsBurban and slovcan like this.
  3. slovcan

    slovcan Newbie

    Messages:
    32
    Likes Received:
    34
    Joined:
    Nov 6, 2020
    Location:
    Centreville, Nova Scotia
    Good idea. I will certainly do that and see what I get. The eBay page says doesn't ship to Canada, but no harm in asking.
     
    Ehall8702 and HotWheelsBurban like this.
  4. slovcan

    slovcan Newbie

    Messages:
    32
    Likes Received:
    34
    Joined:
    Nov 6, 2020
    Location:
    Centreville, Nova Scotia
    Hi folks, I'm back. So, I ordered a couple of AC Delco sensors from Rock Auto. It is the left front that is acting up most, if not all, the time. When coming to a stop MOST of the time it activates, the steering wheel will roll to the right just a bit indicating the left brake has released. The fellow who is doing it for me was willing to pull it, sand the rust off the hub clean the sensor and put it back in. I figured I'd better have a replacement on hand in case the original breaks when getting pulled out.

    After thinking about it, and discovering that the left and right are not interchangeable, I ordered both. Since I have to pay for the labour at this time (still a gimp) I think I will just get him to put in the two new ones and be done with it. I'll clean up the ones that come out (if still in one piece) and keep them for spares. He can plug in his scan tool to see which one is failing, but I'm still thinking to replace both anyway.

    About the hub assemblies, good ones were going to be $200+ each by the time I got them here. The sensors are $50 each shipped.

    Cheers,
    Glenn
     
    HotWheelsBurban likes this.

Share This Page