1994 GMC Sierra Ls Swap

Discussion in 'Street Build Threads' started by RolandoLowko, Oct 21, 2019.

  1. RolandoLowko

    RolandoLowko Newbie

    Messages:
    29
    Likes Received:
    16
    Joined:
    Jan 4, 2018
    Location:
    Phoenix,Arizona
    Im using the Stock 02 PCM from the Sub I got it flashed by Bauer's Performance Tuning.
     
    TheAutumnWind likes this.
  2. RolandoLowko

    RolandoLowko Newbie

    Messages:
    29
    Likes Received:
    16
    Joined:
    Jan 4, 2018
    Location:
    Phoenix,Arizona
    Got the whole front clip back on with Rad,Con,Trans cooler gonna be installing Upper radiator hose today running the Steam lines also install the P/S pump.

    BC7618D6-141A-449D-BD87-B4A77886F0D0.jpeg
     
    Dubs and TheAutumnWind like this.
  3. labarrejr

    labarrejr Newbie

    Messages:
    8
    Likes Received:
    0
    Joined:
    Jan 4, 2017
    Location:
    Plantation, Fla
    how are you getting the new engine to communicate with your gauge cluster?
     
  4. RolandoLowko

    RolandoLowko Newbie

    Messages:
    29
    Likes Received:
    16
    Joined:
    Jan 4, 2018
    Location:
    Phoenix,Arizona
    For the Coolant Temp im going with 3 wire sensor from a 98 Camaro V6 Black and yellow wires go to the PCM from the LS Green wire from the original harness on the truck which is green wire as well the Volts you use the Alternator single wire from the original truck harness. the oil pressure you gonna have to use the original Sending unit from the 350 with an Adapter since the thread pitch is different on the LS Block.
     
    andremora71 likes this.
  5. andremora71

    andremora71 Newbie

    Age:
    48
    Messages:
    15
    Likes Received:
    6
    Joined:
    Aug 12, 2018
    Location:
    US
    Planning on doing the same thing ! I have the moonie gauges, wondering how you are gonna hook up the factory speedo? Or you going to run aftermarket?

    Sent from my SM-N960U using Tapatalk
     
  6. Jglew82

    Jglew82 I fix stuff

    Age:
    36
    Messages:
    252
    Likes Received:
    129
    Joined:
    Feb 9, 2018
    Location:
    Texas
    For my moonies, I "T'd" into the speed sensor wires from the speed sensor to the PCM as follows: Green vss low signal on the LS harness to purple low vss signal on your truck, and purple vss high signal on LS harness to your yellow vss high signal on your truck. My gauge works perfectly.

    On the 92-94 gauges, you can bypass the DRAC and take the signal outputs from the LS pcm (tac and speed) directly to the cluster which is nice because you can change the tire size and gear ratios with HPtuners or whatever, and it'll correct the readings.

    Moonies, you will still need to change the old school way, or upgrade to the 92-94 cluster.
     
    TheAutumnWind likes this.
  7. RolandoLowko

    RolandoLowko Newbie

    Messages:
    29
    Likes Received:
    16
    Joined:
    Jan 4, 2018
    Location:
    Phoenix,Arizona
    Finally Took it on a first test drive feels great just needs Exhaust just open headers :D but i got the front clip back on :) today im going wire up my Tac and Speedo hopefully get it working ;)

    921D47BE-1C84-4BF9-BDFA-42DD1A03A9E4.jpeg

    EF9FBE0C-361C-40F7-9D48-4D1C877F2FE4.jpeg
     
    Dubs, TheAutumnWind and Raulfelix24 like this.
  8. TheAutumnWind

    TheAutumnWind I'm Awesome

    Messages:
    205
    Likes Received:
    73
    Joined:
    Feb 11, 2019
    Location:
    California
    You work fast! Looks like it belongs in there.
     
    RolandoLowko likes this.
  9. RolandoLowko

    RolandoLowko Newbie

    Messages:
    29
    Likes Received:
    16
    Joined:
    Jan 4, 2018
    Location:
    Phoenix,Arizona
    Im having trouble trying to find the Tach wire (white) you by any chance have an exact location were its coming from i dont really want to take apart all the loom coming from the Cluster :(:D
     
  10. Jglew82

    Jglew82 I fix stuff

    Age:
    36
    Messages:
    252
    Likes Received:
    129
    Joined:
    Feb 9, 2018
    Location:
    Texas
    Should have been coming out of the engine harness right by where your coil/pickup wires came out. If for some reason you can't find it, it's pin "T" on the cluster connector.
     

Share This Page