Recent content by Matt98

  1. Matt98

    Non- A/C Heater Box.

    Alright I’ve done my swap today...my factory non A/C truck (92) has the exact same box as one with A/C (98), the difference being the actual mode doors have levers moulded on instead of a piece to add an actuator, as well as the blower housing has a slightly different recirculate door as it’s...
  2. Matt98

    Non- A/C Heater Box.

    I believe for the most part the AC/Non AC heater boxes are the same in all GMT 400 trucks. I can confirm this tomorrow, I'll be putting an AC box out of a 98 in my 92 with no ac. The controls are different in the earlier ones without AC anyhow, as they are cable vs electric on the ac/new ones...
  3. Matt98

    Big parasitic draw and already tested all circuits

    Depends on the truck though, whos to say there isnt some sort of aftermarket alarm that decides it wants to set all the lights/horn off as soon as the battery is hooked up. Just a preventative procedure.
  4. Matt98

    Big parasitic draw and already tested all circuits

    I know a lot of this has been stated, but test the battery first. If it’s good, get a cheap meter and hook it between the negative terminal and cable. It’s in your best interest to disconnect the negative terminal then run a jumper wire from that to the battery, wait a few seconds, hook your...
  5. Matt98

    Parking brake adjuster

    No that joins the front cable to the rear cable, this one joins the left and right cables together
  6. Matt98

    Parking brake adjuster

    Before I even put it on I squeezed the clamp a bit tighter but nothing, and theres nothing that holds the other cable in place on the other side, it just flexes under pressure and opens up. I ended up putting my old one back on (which is also that same dorman one) What I did there was cut the...
  7. Matt98

    Front brakes help!

    Not true, Powerstop brakes for sure say to bed them in right on the box. I've had AC Delco pads squeak a few times and the pad physically looks hard, which I believe from whoever doing the brakes not bedding them in properly. It also really helps on rotors where the whole surface is coated to...
  8. Matt98

    Parking brake adjuster

    Hi, A couple years ago I changed the rear cables and the equalizer/adjuster on my parking brake (The adjuster snapped). The only one I could get was by Dorman and as soon as I went to apply it with any bit of tension the one cable pulled through. I fixed it by adding a hose clamp there. Then...
  9. Matt98

    Engine knock issue

    EGR was my first thought, though as far as I know the engine never had an EGR. There's nothing in any vacuum lines I ran them all, the engine itself came out of a trans am I got that was rough, so I'm not sure exactly what was done to it in the past, nor did I drive it before pulling the motor...
  10. Matt98

    Engine knock issue

    Base is set to 8 degrees, total is 31 degrees ATM with the vac advance disconnected. I'm not sure exactly how much advance the vacuum advance adds but its a stock distributor. Like I said the engine sounds happy right now but If I'm sitting at about 14" of vacuum right now, if I advance the...
  11. Matt98

    Engine knock issue

    I've done some playing around with it. I got it to run really well with the light springs and the vacuum advance disconnected. Running 31 degrees of total advance. However it seems like it likes more timing at idle, so I need to hook that back up. I'm wondering how I should go about this, if...
  12. Matt98

    Engine knock issue

    Yes HEI. I'm running a moroso advance kit. I started with the heavy springs, though if memory recalls it still did it, maybe i'll try again. It's been a while since I played with it and I don't remember why i switched them out. Currently running the light ones and reduced my total timing...
  13. Matt98

    Engine knock issue

    Hi, I have a 1992 that I've swapped the engine with a 305 out of an 84 camaro. I don't know everything that was done to the engine, as I got the car because it was abandoned. I do however know it has 0.030 over pistons as well as a mild cam. Also running an edelbrock 600 The issue I'm having...
Top