Suspension vibration

Discussion in 'Stock Suspension + Bolt On Kits' started by blackhawk17, Apr 10, 2018.

  1. blackhawk17

    blackhawk17 OBS Enthusiast

    Messages:
    78
    Likes Received:
    20
    Joined:
    Dec 28, 2012
    Location:
    Khowst, Afghanistan
    I’m trying to determine what would cause a vibration in the rear suspension after hitting a bump. It wasn’t really noticeable until I added add-a-leafs in the back with my old stock springs. I’m guessing that the stiffer, newer leaf is buffeting against the old springs, kind of propagating a vibration through the frame that I can feel all the way up front.

    Has anyone experienced this sort of thing? I’ve got new shocks throughout when I did a 2 inch lift, but I’m surprised it doesn’t really ride any better. I’m hoping that I just need to replace the springs all the he way around, because that’s a simpler fix than other possibilities.

    The old springs do have 250,000+ miles on them, so they’re certainly due for replacement. I’m just hoping that it’s not something like my frame is old and floats around, etc.


    Sent from my iPhone using Tapatalk
     
    Eskimomann209 likes this.
  2. blackhawk17

    blackhawk17 OBS Enthusiast

    Messages:
    78
    Likes Received:
    20
    Joined:
    Dec 28, 2012
    Location:
    Khowst, Afghanistan
    This is the truck in question...[​IMG]


    Sent from my iPhone using Tapatalk
     
  3. GarrettGmc

    GarrettGmc I'm Awesome

    Messages:
    1,446
    Likes Received:
    476
    Joined:
    Mar 25, 2017
    Location:
    Cottonwood Ca
    How's the body mounts? Just throwing a guess that mayb the mounts are worn so now it could feel worse.
     
  4. blackhawk17

    blackhawk17 OBS Enthusiast

    Messages:
    78
    Likes Received:
    20
    Joined:
    Dec 28, 2012
    Location:
    Khowst, Afghanistan
    No doubt the body mounts do need replacing. That is something I do need to look at doing in the relatively near future.


    Sent from my iPhone using Tapatalk
     
  5. Eskimomann209

    Eskimomann209 I'm Awesome

    Age:
    27
    Messages:
    470
    Likes Received:
    77
    Joined:
    Jul 22, 2014
    were you a naughty boy and reused your u bolts?

    Also did u loosen the leaf spring mount bolts?
    Those are supposed to be relatively tight.. then when you drop the suspension ( put the truck back on the springs) torque them...
    then after you tighten the u bolts... drive around a bit and torque them again...
    That’s a clean looking truck though
     
  6. blackhawk17

    blackhawk17 OBS Enthusiast

    Messages:
    78
    Likes Received:
    20
    Joined:
    Dec 28, 2012
    Location:
    Khowst, Afghanistan
    No, I didn’t reuse anything, but I should recheck the torques...


    Sent from my iPhone using Tapatalk
     
  7. retorq

    retorq Newbie

    Messages:
    49
    Likes Received:
    17
    Joined:
    Dec 9, 2010
    Did someone say retorq?
     

Share This Page