Register to remove these ads

No rear parking lights

Discussion in 'Audio + Electronics' started by 5spd Z71, Apr 20, 2011.

  1. 5spd Z71

    5spd Z71 I'm Awesome

    Messages:
    629
    Likes Received:
    10
    Joined:
    Feb 13, 2011
    Location:
    Texas
    Hey guys, I got a strange problem here. I noticed last night while driving, ( thanks to everyone that was flashing me on the roads... ) that my rear lights dont work. The parking lights that it. I have brake lights, turn singals, reverse lights. But no parking lights and no license plate lights either. Im assuming that these are on the same circuit? ( Sorry guys I havent picked up a manual for the truck yet ) But every other light on the truck works. Including all my other parking lights. Just not the rears.

    I did a quick check, and with the parking lights on, Ive got no voltage going back to the circuit boards. But I have voltage when I hit the brakes and turn signals.

    What do you guys think? My first thought was headlight switch, but I dont wanna just go out and throw money at this thing.
     
  2. Swims350

    Swims350 I'm Awesome

    Messages:
    4,134
    Likes Received:
    9
    Joined:
    Mar 28, 2010
    Location:
    Logan Co. WV
    check fuses maybe? do the fronts work? I'd think if the fronts work then the switch and fuse is fine, just maybe a wire came loose or got ripped or something.

    I have the opposite problem now, but I have power, my turn signals and brake lights don't work on the DS but the PS does and parklights work all around. Mines just bad bulbs.
     
  3. 5spd Z71

    5spd Z71 I'm Awesome

    Messages:
    629
    Likes Received:
    10
    Joined:
    Feb 13, 2011
    Location:
    Texas
    Ill have to check all the fuses, but the fronts do work. Looks like Ill have a project to do this weekend :(
     
  4. Swims350

    Swims350 I'm Awesome

    Messages:
    4,134
    Likes Received:
    9
    Joined:
    Mar 28, 2010
    Location:
    Logan Co. WV
    yea if the fronts work then the fuse and switch SHOULD be good. it won't hurt the check, but I wouldn't think they'd have a seperate fuses for front and rear.

    Might check the ground under the bed, and then the lights plugin, both on the DS frame of my 88.

    If you were getting power to the boards I'd say the board of bulb, but since you got no power to the boards, something is broken between the switch and rear lights.
     
  5. capricefrk013

    capricefrk013 Toy Hauler

    Messages:
    494
    Likes Received:
    7
    Joined:
    Dec 3, 2009
    Location:
    NE Ohio
    If you have a trailer harness on the truck trace them back to where they are connected and look for corrosion. Ive seen it numerous times.
     
  6. 5spd Z71

    5spd Z71 I'm Awesome

    Messages:
    629
    Likes Received:
    10
    Joined:
    Feb 13, 2011
    Location:
    Texas
    Ive got power to the boards. The brake lights and turn signals, and reverse all work. Just no parking lights.

    Ill have to check for any corrosion there. it wasnt the cleanest install Ive ever seen..
     
  7. Swims350

    Swims350 I'm Awesome

    Messages:
    4,134
    Likes Received:
    9
    Joined:
    Mar 28, 2010
    Location:
    Logan Co. WV
    well if you got power to the rest maybe the bubls are blown. or the boards only on the parklight part. try a new bulb
     
  8. Goodiemob

    Goodiemob Newbie

    Age:
    32
    Messages:
    23
    Likes Received:
    0
    Joined:
    Apr 4, 2011
    I actually have to flick my switch a couple times to get my rear parking lights to work. Everthing else works just no parking lights. Also my side marker lights dont work when my headlights are on but work when there off?? Gotta love gremlins.
     
  9. 5spd Z71

    5spd Z71 I'm Awesome

    Messages:
    629
    Likes Received:
    10
    Joined:
    Feb 13, 2011
    Location:
    Texas
    Ill have to check the grounds and check the switch. Looks like Ill be looking at wiring diagrams lol but I gotta get this figured out soon. Cuz as it is, I cant drive the truck at night...
     
  10. 5spd Z71

    5spd Z71 I'm Awesome

    Messages:
    629
    Likes Received:
    10
    Joined:
    Feb 13, 2011
    Location:
    Texas
    Winner! scotch locks... had 3 broken wires, and whoever put this in did a complete hack job.

    So needless to say its working for right now. When the box comes off, itll get fixed the right way.
     

Share This Page