Deadbeats 1997 Centurion Conversion

Discussion in 'Member Trucks' started by deadbeat, Dec 1, 2014.

  1. deadbeat

    deadbeat Centurion Crew Cab

    Age:
    33
    Messages:
    645
    Likes Received:
    207
    Joined:
    Nov 30, 2014
    Location:
    Means KY
    Im going to slowly move my pictures over to something else, here they are.

    [​IMG]

    [​IMG]
    [​IMG]
     
    Biggershaft96 likes this.
  2. deadbeat

    deadbeat Centurion Crew Cab

    Age:
    33
    Messages:
    645
    Likes Received:
    207
    Joined:
    Nov 30, 2014
    Location:
    Means KY
    I need to figure out how to size the images correctly for the imgbb site.
     
  3. Old77

    Old77 I'm Awesome

    Messages:
    1,534
    Likes Received:
    82
    Joined:
    Dec 27, 2013
    those seats look great!
     
  4. Iblemz

    Iblemz Newbie

    Messages:
    18
    Likes Received:
    1
    Joined:
    Aug 1, 2016
    Location:
    Lauderhill
    Sweet !

    Sent from my SM-G930P using Tapatalk
     
  5. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    165
    Likes Received:
    38
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    Forgive my ignorance, but what is a Centurion?
     
  6. rojas84

    rojas84 Newbie

    Messages:
    30
    Likes Received:
    19
    Joined:
    Feb 2, 2010
    It's a company that converted single cabs to crew cabs


    Sent from my SM-G920T using Tapatalk
     
    94burbk1500 likes this.
  7. 94burbk1500

    94burbk1500 I'm Awesome

    Messages:
    165
    Likes Received:
    38
    Joined:
    Jul 13, 2017
    Location:
    Bucks County, PA
    Cool, thanks
     
  8. deadbeat

    deadbeat Centurion Crew Cab

    Age:
    33
    Messages:
    645
    Likes Received:
    207
    Joined:
    Nov 30, 2014
    Location:
    Means KY
    I still have yet to find a scanner that will read my codes, but I did find a broken coolant sensor and replaced it the other day. The thing missed like crazy with it plugged in but would run fine with it unplugged, although it was hard to get started. Finally I double checked the part number and noticed they sell the pigtail so I took all the wires apart and although the plug looked good, I cleaned it really good and plugged it back in and drove it some, the light went out and it hasn't missed in about 100 miles.
     
    deejaaa likes this.

Share This Page