Cold engine dies right away

Discussion in 'Engine Performance + Maintenance' started by BIG_KID, Jan 7, 2017.

  1. BIG_KID

    BIG_KID I'm Awesome

    Messages:
    114
    Likes Received:
    25
    Joined:
    Dec 5, 2016
    Location:
    Northern indiana
    bone stock 5.7 initial cold starts up then dies right away. Restarts then runs fine. Does this almost every time when cold, starts/runs fine when warm. Any advise
     
  2. GL1500

    GL1500 I'm Awesome

    Messages:
    113
    Likes Received:
    41
    Joined:
    Feb 29, 2016
    Location:
    Byron Center MI
    I just had this happen yesterday when temps were around 10*. I found I could keep it running if I kept my foot lightly on the gas. Happened twice then next time I went to start it it idled and ran fine. I figured it might be the throttle position sensor going south so next time it wouldn't start I rapped on the TPS and wiggled the wires and it's been fine since. Ran fine today but I can't trust it so I'll pick up another soon.

    Best wishes
     
  3. BIG_KID

    BIG_KID I'm Awesome

    Messages:
    114
    Likes Received:
    25
    Joined:
    Dec 5, 2016
    Location:
    Northern indiana
    TPS on mine is new and set at .5VDC
     
  4. jkeaton

    jkeaton I need a beer.

    Messages:
    1,470
    Likes Received:
    208
    Joined:
    Jan 1, 2013
    Location:
    Winston Salem, NC
    I'd suspect the IAC.
     
  5. BIG_KID

    BIG_KID I'm Awesome

    Messages:
    114
    Likes Received:
    25
    Joined:
    Dec 5, 2016
    Location:
    Northern indiana
    Also brand new
     
  6. NacIK

    NacIK aka Dirty Hoe

    Age:
    33
    Messages:
    381
    Likes Received:
    9
    Joined:
    Jan 11, 2010
    Location:
    Ft. Bragg, NC
    IAT. Just went through the same thing with mine. I thought it was the distributor since I just rebuilt and put it together but it ended up being the intake sensor. It was showing 90 degrees out when it was 12.
     
  7. BIG_KID

    BIG_KID I'm Awesome

    Messages:
    114
    Likes Received:
    25
    Joined:
    Dec 5, 2016
    Location:
    Northern indiana
    I should of said the year of my truck (1991)
    I don't believe it uses a IAT sensor
     
  8. NacIK

    NacIK aka Dirty Hoe

    Age:
    33
    Messages:
    381
    Likes Received:
    9
    Joined:
    Jan 11, 2010
    Location:
    Ft. Bragg, NC
    Oh, scratch that, something else.
     
  9. jkeaton

    jkeaton I need a beer.

    Messages:
    1,470
    Likes Received:
    208
    Joined:
    Jan 1, 2013
    Location:
    Winston Salem, NC
    Coolant temp sensor?
     
  10. BIG_KID

    BIG_KID I'm Awesome

    Messages:
    114
    Likes Received:
    25
    Joined:
    Dec 5, 2016
    Location:
    Northern indiana
    Also new and verified with ohm meter
     

Share This Page