97 Silverado, no oil pressure and stalls out

Discussion in 'Engine Performance + Maintenance' started by Luke(MI), Aug 28, 2011.

  1. Luke(MI)

    Luke(MI) Blow Smoke

    Messages:
    231
    Likes Received:
    0
    Joined:
    Aug 28, 2011
    Location:
    Pewamo, MI
    A friend of mine has a 97 Silverado with the Vortec 5.7 and it suddenly lost oil pressure and runs shitty if it starts then stalls, I told him it sounds like the oil pump and fuel pump took a s hit around the same time, but do the Vortec's even use oil pumps? The truck has around 95000 last I knew, and I know these fuel pumps are due at about 100000
     
  2. k_pro1992

    k_pro1992 I'm Awesome

    Messages:
    264
    Likes Received:
    1
    Joined:
    Feb 2, 2011
    Location:
    SC
    when mine did that the rod connecting the distributor to the oil pump broke and spun a main bearing.
     
  3. Luke(MI)

    Luke(MI) Blow Smoke

    Messages:
    231
    Likes Received:
    0
    Joined:
    Aug 28, 2011
    Location:
    Pewamo, MI
    Thats almost a complete tear down isnt it?
     
  4. k_pro1992

    k_pro1992 I'm Awesome

    Messages:
    264
    Likes Received:
    1
    Joined:
    Feb 2, 2011
    Location:
    SC
    yeah, its a complete teardown but maybe the oil pump just quit so drop the pan and change the oil pump and maybe its a simple fix. maybe someone who knows more about building motors can chime in and give more advice.
     
  5. k_pro1992

    k_pro1992 I'm Awesome

    Messages:
    264
    Likes Received:
    1
    Joined:
    Feb 2, 2011
    Location:
    SC
    i wouldn't attemp to drive it though cause the engine not being lubricated properly could cause alot more problems costing more to repair.
     
  6. Mean Green

    Mean Green I'm Awesome

    Messages:
    5,298
    Likes Received:
    73
    Joined:
    Jan 17, 2011
    Location:
    Minnesota
    Have you considered the possibility that the two may be compeltey unrelated? Is there NO oil preasure or just low oil preasure? Your oil preasure sending unit could of failed, thus showing no oil preasure on the gauge! The stalling issue almost sound like an electrical issue, could be fuel also. Have you checked the fuel preasure in line?
     
  7. DRAGGIN95

    DRAGGIN95 Warranty Killer! Staff Member

    Age:
    37
    Messages:
    9,833
    Likes Received:
    93
    Joined:
    Dec 5, 2009
    Location:
    Antioch Arkansas
    I know the TBI truck's do, but does the fuel pump on these vortec truck's get shutoff after a few seconds of no oil pressure?
     
  8. Luke(MI)

    Luke(MI) Blow Smoke

    Messages:
    231
    Likes Received:
    0
    Joined:
    Aug 28, 2011
    Location:
    Pewamo, MI
    They both happend at the exact same time, so I figure it's likely related. I haven't talked to him in a while, I'll ask him this monday.
     
  9. Tinbender59

    Tinbender59 I AM JUST PLUM CRAZY

    Messages:
    283
    Likes Received:
    3
    Joined:
    Mar 17, 2011
    Location:
    Kansas
    wow someone does pay attention to the tech manual????? sounds like a sender took a shite then the fuel would be cut off, or if the sender is sparatic "faster the the guage can react" then fuel pressure would be ah--------- well the thing would drive, like real crazzy.
     
  10. silverado13

    silverado13 GEAR HEAD

    Messages:
    1,081
    Likes Received:
    3
    Joined:
    Mar 4, 2011
    Location:
    Baton Rouge Louisiana
    yeah i heard that the fuel pump will shut off if you dont have any oil pressure as a procaution but a buddy of mine has a 2000 tahoe limited and his oil pump died and he melted the engine so ive never been sure about that
     

Share This Page