Register to remove these ads

5.7L Vortec Injector housing and Manifold

Discussion in 'Engine Performance + Maintenance' started by UrbanOffroad215, Aug 16, 2010.

  1. UrbanOffroad215

    UrbanOffroad215 Newbie

    Messages:
    49
    Likes Received:
    0
    Joined:
    Aug 16, 2010
    Location:
    Philadelphia, PA
    5.7L Vortec SFI

    Hello everyone,
    I am new to this forum and have a simple (but probably stupid) question.

    Problem: Few days ago my truck started idling funny while i was sitting at a red light and i began to hear air hissing..so right away i think "vacuum line. I searched for this apparent disconnected vacuum line and found nothing...after further searching i noticed that my fuel injector housing (spider injector) has dropped into the intake manifold. I took everything apart and removed the manifold and injector housing, Bought all new gaskets and got ready to put everything back together. I am not very "mechanically" inclined..but i do know how to turn a wrench..My profession is body repair.

    Question: How does the injector housing attach to the manifold? It looks as if it should be 'pressed' into the manifold, but by looking at it..i cant seem to find out how it would have came out of the manifold if it is pressed. There is no damage at all (except a ripped gasket). Should there be something holding it in place? There just seems to be WAY to much vacuum pressure for it to just sit there..

    The only diagrams i can find show an "exploded" version of the manifold and i dont seem to be missing any parts that i can see..
     
  2. Lextech

    Lextech I'm Awesome

    Age:
    52
    Messages:
    124
    Likes Received:
    10
    Joined:
    Jan 6, 2010
    Location:
    Oak Forest, Illinois
    There is a steel bracket inside the manifold that holds the injector half of the connector. That bracket is pretty tough--I wouldn't think it got bent. The seal on the connector half is a snug fit into the upper plenum. Put some lube on the seal and while positioning the upper plenum back onto the lower manifold--wiggle and pull up on the connector to get it to "seat" into the upper plenum. Then, bolt the upper plenum to the lower manifold.

    Jeff
     
    1 person likes this.
  3. UrbanOffroad215

    UrbanOffroad215 Newbie

    Messages:
    49
    Likes Received:
    0
    Joined:
    Aug 16, 2010
    Location:
    Philadelphia, PA
    Thanks for the information...

    I took a look today and did not see a bracket...it was not there when i took the manifold apart either. However i did manage to put the injector housing back into the top portion of the manifold and it seems to seat in just fine. I replaced all of the gaskets and o-rings and it does not look like it will come loose again (fingers crossed)..But i did notice there was two threaded holes on the lower manifold..as if something should be mounted there. After going over the diagrams that i have..and looking through parts catalogs and lists..i found nothing that seems to be bolted there. I went to a local Chevrolet dealership and their computers showed the same as my diagram.

    Since the injector housing seemed to be alright and in place..i put the manifold back together and buttoned everything up...the truck started and ran great for about 10 minutes and then started to bog and struggle to stay running. I checked my repair on the injector housing and it looks to be fine and has not moved. While driving, everything seems fine, But when i come to a stop it starts to 'gurgle' and bog down. If the truck is in 'park' it is okay..but if i hold the brake while in gear it wants to shut down. I am really stuck at this point and have run out of ideas. All vacuum lines and connectors are in place as they should.

    Any ideas?
     
  4. Mike

    Mike Administrator Deluxe Staff Member

    Messages:
    1,587
    Likes Received:
    14
    Joined:
    Dec 2, 2009
    Location:
    Mass.
    Throwing any engine codes? Triple check all your electronic connections.
     
  5. UrbanOffroad215

    UrbanOffroad215 Newbie

    Messages:
    49
    Likes Received:
    0
    Joined:
    Aug 16, 2010
    Location:
    Philadelphia, PA
    I am showing a code but believe it is for either an o2-sensor or one of my catalytic converters..the code reads out "cat bank 2", But that has been showing since before my current issue..i was trying to save a little extra money to fix the cat-conv ($900) and then this happened. So the exhaust is on the back burner for now, Had a friend check the OBD and it just shows the same code..nothing else.

    Went over all my connections again today and also cleaned them, All vacuum lines are connected and seated properly
     
  6. Gentry95

    Gentry95 Newbie

    Messages:
    1
    Likes Received:
    0
    Joined:
    Aug 24, 2010
    Location:
    California, MO
    I had a similar issue with my 95 Jimmy, and the code sounds familiar. Jimmy with 4.3L Vortec 4x4 SLT, My cat had fallen apart inside and clogged both the cat and muffler. It ran fine down the road, but sitting would bog and Die. Im not sure if your problem could be the same, just figured I'd throw it out there.
     
  7. Mike

    Mike Administrator Deluxe Staff Member

    Messages:
    1,587
    Likes Received:
    14
    Joined:
    Dec 2, 2009
    Location:
    Mass.
    Engine can't run without proper o2 readings.
     
  8. jaemitch

    jaemitch Newbie

    Age:
    34
    Messages:
    42
    Likes Received:
    0
    Joined:
    Dec 12, 2009
    Location:
    Beaumont TX.
    i just fixed mine from doing the same thing i changed plugs, o2 sensor that the code was tellin me still shook bad, then i changed the fuel filter cleaned EGR valve and IAC and now shes back to her old self. try that and see if it helps.
     
  9. UrbanOffroad215

    UrbanOffroad215 Newbie

    Messages:
    49
    Likes Received:
    0
    Joined:
    Aug 16, 2010
    Location:
    Philadelphia, PA
    I did some checking around...and you were right about the bracket...but for some strange reason it was not inside the manifold when i took everything apart...which means that some idiot never put it back it while they had the manifold apart before me..

    The problem i am having is that i cannot find this bracket anywhere...I have check all my local junkyards but have not had any luck locating one..and of course in my area all the local parts stores (pep boys,autozone,etc...) have idiots working for them..apparently you dont need to know anything about cars or parts to work in these places..

    Does anyone know where i can locate/purchase this bracket?
     
  10. MIHELA

    MIHELA Nooo! Noooooo

    Messages:
    502
    Likes Received:
    2
    Joined:
    Dec 9, 2009
    Location:
    Sioux Falls, SD
    Dealer.
     

Share This Page