GMT400 - The Ultimate 88-98 GM Truck Forum - Powered by vBulletin

Register to remove these ads



Results 1 to 7 of 7
  1. #1
    I'm Awesome Bigg G's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    568
    Rep Power
    63

    Default 4L60E Valve Body

    I did a little reading on 4L60E tranny issues related to hard 1st-2nd gear shifts and light shift slipping issues and found a few sellers with good reputations selling rebuilt valve bodies but I have a few questions.

    Has anyone here done the swap ?
    How hard is to to replace the valve body in that tranny ?
    Is it just a matter of draining the fluid, dropping the tranny pan and removing the valve body ?
    Are any speciality tools needed ?

  2. #2
    I'm Awesome bluebear15's Avatar
    Join Date
    Dec 2009
    Age
    25
    Posts
    128
    Rep Power
    0

    Default

    http://www.gmt400.com/forum/showthread.php?254-P1870

    P1870 is the check engine code that is for that hard 1-2 shift that is the worn tcc apply valve. you can compare doing it yourself to other shop rates. the only special tool you need doing it yourself is the reamer. doing it yourself could cost up around $200
    Ryan - 97 Tahoe: 3" BL, 285/75/16, ///Alpine HU

  3. #3
    I'm Awesome 6chevy9's Avatar
    Join Date
    Jan 2010
    Location
    pinckney mi
    Age
    26
    Posts
    1,243
    Rep Power
    76

    Default

    i have heard of there being a line pressure adjustment that will make it shift very hard. idk if this is true info but an idea at the least.
    97 rcsb 355cid DIY cold air intake throttle body spacer home made exhaust 3 inch body lift keys add a leaf and 33/12.50 bfg mud SOLD!

    98 gmc ecsb, 16.5 inches of lift. 454, 4l80, Dana 60 40" tires.

  4. #4
    I'm Awesome Bigg G's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    568
    Rep Power
    63

    Default

    Even though I don't have any history on the tranny in my truck I'm pretty sure it's not the original because it's completely painted GM Orange including the tranny pan plus the dust sheild was missing when I bought the truck a few years ago. The truck doesn't throw any CEL codes but the 1st-2nd gear shift can be hard enough to chirp the rear wheels if I leave hard enough from a full stop. 2nd-3rd-4th (overdrive) shifts are nice and smooth. The tranny fluid is cherry red and there is no ordor of it being burned. I installed a new TCS a few months back and it did smooth out the 1st-2nd shift a tadd but it's still not shifting as smooth as I think it should.

    I guess I'll have to ask a buddy about doing that worn valve body deal in my 4L60 because that sounds like the same issue I'm having.

  5. #5
    I'm Awesome Hodges87's Avatar
    Join Date
    Dec 2009
    Location
    Texas
    Age
    32
    Posts
    249
    Rep Power
    63

    Default

    Here are some valve body removal & installation videos:

    Removal: http://www.youtube.com/watch?v=6Svl0...eature=channel

    Tear down: http://www.youtube.com/watch?v=1cjli...eature=channel

    Install: http://www.youtube.com/watch?v=leR6K...eature=channel

    Its not that hard to do, just take your time and follow the video closely.
    Sold!|97 Z71 5.7L|F44|14 Bolt SF|Magna-flow Cats|AD244 Upgrade|MSD Wires|Corvette Servo|Flowmaster Super 40 DI/DO|Royal Purple 5W-30|

    New Truck: 05 CCSB Duramax LLY 4x4

  6. #6
    I'm Awesome Bigg G's Avatar
    Join Date
    Jan 2010
    Location
    Maryland
    Posts
    568
    Rep Power
    63

    Default

    Thanks for posting.....I'll definetly peep those out.

  7. #7
    I'm Awesome 98chevy4x4's Avatar
    Join Date
    Jul 2010
    Location
    Smithville, TN
    Age
    21
    Posts
    183
    Rep Power
    51

    Default

    Are you sure when you bought it the trans didnt have a shift kit installed in it

    355 vortec,4l60e trans,3:42 gears
    tbs,billet servo,
    efan,bypassed 2 pulleys
    18" hostages and wildpeak 305's
    LT hookers flowmaster 44s dumped
    WAY MORE TO COME

Similar Threads

  1. The Body Lift Thread
    By squeaky3 in forum Stock Suspension + Bolt On Kits
    Replies: 728
    Last Post: 07-19-2014, 07:46 PM
  2. 4L60E Messed up? Help Within
    By Ginger in forum Transmissions
    Replies: 23
    Last Post: 06-19-2014, 07:35 PM
  3. 4l60e vette servo install
    By Ginger in forum Transmissions
    Replies: 19
    Last Post: 06-12-2014, 09:28 AM
  4. 4l60E dipstick tube broken
    By willinthe985 in forum Transmissions
    Replies: 3
    Last Post: 12-02-2010, 11:45 AM
  5. 4L60e ---> 4L80e
    By Butch in forum Transmissions
    Replies: 10
    Last Post: 01-17-2010, 09:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •