GMT400 - The Ultimate 88-98 GM Truck Forum - Powered by vBulletin

Register to remove these ads



Results 1 to 2 of 2

Thread: PO161 o2 sensor

  1. #1
    Newbie
    Join Date
    Nov 2010
    Age
    62
    Posts
    1
    Rep Power
    0

    Default PO161 o2 sensor

    Hi Guys, I had trouble code PO161 come up- Bank 2 Sensor 2 O2 sensor heater malfuntion. Replaced the sensor, cleared the code but code keeps coming back. Checked the connection which seemed O.K. Anyone else have this prob? Thanks for any info.

  2. #2
    I'm Awesome tylers88's Avatar
    Join Date
    Nov 2010
    Location
    Clarion, IA
    Age
    23
    Posts
    365
    Rep Power
    54

    Default

    If its a heater and the wiring is good replace the sensor

    We are Professional Grade

Similar Threads

  1. which one is my MAF sensor? Pics included
    By jshawag12 in forum Engine Performance + Maintenance
    Replies: 12
    Last Post: 08-16-2010, 12:17 AM
  2. MAF sensor?
    By Laydout98 in forum Engine Performance + Maintenance
    Replies: 11
    Last Post: 08-05-2010, 02:23 PM
  3. Granetelli Mass Airflow Sensor
    By bowtiefreak in forum For Sale
    Replies: 0
    Last Post: 07-30-2010, 05:09 PM
  4. Oxygen Sensor 96 K1500 4L60-E
    By dcZ71 in forum Engine Performance + Maintenance
    Replies: 9
    Last Post: 04-13-2010, 07:39 AM
  5. Bank 1 Sensor 2
    By jaemitch in forum Engine Performance + Maintenance
    Replies: 5
    Last Post: 12-15-2009, 07:05 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •